Some extractions are returning mocked data from sandbox in the production environment.
Incident Report for Syntage.com
Resolved
We have reprocessed all extractions created during the affected window. Customers with API integrations should delete/discard any data received and stored between 12:18 and 16:22 (Mexico Time). We apologize for the inconvenience caused by this incident. For further questions, feel free to contact our customer support team at https://support.syntage.com/hc/es or via WhatsApp at +52 55 6943 7840.
Posted Apr 01, 2024 - 22:55 CST
Update
At this time extractions are running normally.
Posted Apr 01, 2024 - 22:10 CST
Monitoring
At this time all mock data has been removed from the system. We are currently reprocessing all extractions created during the affected window. Scheduled extractions will be created shortly.
Posted Apr 01, 2024 - 21:09 CST
Update
Today at 12:18pm (Mexico City time), a minor deployment was made to production. This deployment included a patch version of a well-known library that unintentionally introduced a breaking change affecting how environment parameters are handled. As a result, our production environment started behaving like a sandbox. We will delete all mock data created by extractions post 12:18pm and re-run extractions to ensure real data is in place. Extractions will remain paused until sandbox data is removed from the product.
Posted Apr 01, 2024 - 18:06 CST
Investigating
We are investigating the issue’s scope. Extractions will be paused until we identify the root cause. We will provide updates as soon as possible.
Posted Apr 01, 2024 - 16:52 CST
This incident affected: Extractions (Invoice, Annual Tax Returns, Provisional Tax Returns, RIF Tax Returns, Tax Status, Tax Compliance, Tax Retention, Electronic Accounting, RPC, Extraction Scheduler).